Location via proxy:   [ UP ]  
[Report a bug]   [Manage cookies]                

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Sep 10 13:56
    drmason13 review_requested #6542
  • Sep 10 13:56
    drmason13 opened #6542
  • Sep 07 18:26
    ceciliaavila added as member
  • Aug 04 22:02
    dmvtech added as member
  • Jun 21 16:38

    clearab on ac-pyjava

    readme updates (compare)

  • Jun 13 13:08

    gabog on main

    Update README.md (#6517) remov… (compare)

  • Jun 13 13:08

    gabog on clearab-patch-1

    (compare)

  • Jun 13 13:08
    gabog closed #6517
  • Jun 10 22:03
    clearab review_requested #6517
  • Jun 10 22:03
    clearab unassigned #6517
  • Jun 10 22:02
    clearab assigned #6517
  • Jun 10 22:02
    clearab review_requested #6517
  • Jun 10 22:02
    clearab opened #6517
  • Jun 10 22:02

    clearab on clearab-patch-1

    Update README.md removing refe… (compare)

  • May 24 18:30

    tracyboehrer on main

    Microsoft mandatory file (#6511… (compare)

  • May 24 18:30

    tracyboehrer on GitHubPolicyService

    (compare)

  • May 24 18:30
    tracyboehrer closed #6511
  • May 23 20:02

    microsoft-github-policy-service[bot] on GitHubPolicyService

    (compare)

  • May 23 20:02

    microsoft-github-policy-service[bot] on GitHubPolicyService

    Microsoft mandatory file (compare)

  • May 23 20:02
    microsoft-github-policy-service[bot] opened #6511
Samy Lahfa
@AkechiShiro
Hi, I'm trying to start the default EchoBot however I ran into aiohttp.web_exceptions.HTTPNotFound : Not Found error, is there anyone that ran into this issue as well ?
I'm using Python and I've followed the tutorial given here https://docs.microsoft.com/en-us/azure/bot-service/bot-service-quickstart-create-bot?view=azure-bot-service-4.0&tabs=python%2Cvs
Samy Lahfa
@AkechiShiro
Actually the bot works it just that when I go to the page for the localhost:port_number it throws this error but it doesn't look like this affects the usability of the bot.
Harikishore
@hka047
Can we use azure qna service as a docker container solution ?
shamimjlp
@shamimjlp
Hi Everyone, have you guys implement any sanitizer for html,sql injection in Bot Framework?
Flabo
@flabodotes
Hello everyone, I'm trying to connect my bot using Teams Channel. Using it directly with the GUID works ok, but in the Microsoft Docs say that is not a good practice:
https://docs.microsoft.com/en-us/azure/bot-service/channel-connect-teams?view=azure-bot-service-4.0 Why?? I'm trying the integration as an App but is not workin.
Robert Strzępka
@robertstrz
Hello, I would like to know how the communication between Teams Bot and Azure Bot Service (where the messaging endpoint is set) is secured ? Is it secured somehow by default ?
Bruno Louzada
@BLouzada
Hi guys, I'm using Teams App Studio to develop a bot using webhooks does this include any extra costs? I did not found anything about costs in docs
1 reply
Flabo
@flabodotes

Hello, I would like to know how the communication between Teams Bot and Azure Bot Service (where the messaging endpoint is set) is secured ? Is it secured somehow by default ?

When you connect your bot with the Teams channel the endpoint to use it is like https://teams.microsoft.com/l/chat/0/0?users=28:9bc78230-d5ee-43fb-87a8, It's an https but I can't see more

Hi guys, I'm using Teams App Studio to develop a bot using webhooks does this include any extra costs? I did not found anything about costs in docs

I think that the Teams App are published in your Teams tenant and It's for free.

1 reply
Melih Ozturk
@melih154

Hi all, building a bot (.NET Core SDK v4) with MS Teams Channel, where corporate Azure Network does not allow MS Teams SaaS to connect Azure Bot Service directly due to network settings. Trying to implement a Proxy API on API Gateway for MS Teams to consume and pass the request to Azure Bot Service.

  1. Is this a valid option? How should we configure the communication from Azure Bot Service to MS Teams (ie. bot sends a message to user) Does MS Teams app polls the API or websocket etc. connection created between Azure Bot Service and MS Teams, which can't be replicated through API Gateway?

This requires importing OpenAPI Spec of the Azure Bot SDK. Is there any OpenSpec definition? Using .NET SDK and Swagger to generate OpenAPI document from existing API project generates below document, which is having error while importing it from API Gateway.

{
  "openapi": "3.0.1",
  "info": {
    "title": "ChatBot.Bot",
    "version": "1.0"
  },
  "paths": {
    "/api/messages": {
      "post": {
        "tags": [
          "Messages"
        ],
        "responses": {
          "200": {
            "description": "Success"
          }
        }
      },
      "get": {
        "tags": [
          "Messages"
        ],
        "responses": {
          "200": {
            "description": "Success"
          }
        }
      }
    }
  },
  "components": { }
}
Дмитрий
@Ussr-eng
how to process attachments sent to a skype group if the bot does not see it, since it is impossible to send an attachment with the tag(@botname)?
Babun
@Lauris01
Hello,
very fresh here. Is it possible to do a chatbot that would make some api requests in the back? what is the best way to get started?
Steven Kanberg
@stevkan
:point_up: February 16, 2022 1:13 AM @Lauris01 - Yes, this is fairly standard practice. Regardless of which BotFramework SDK you use (C#, JS, etc.), set up your API calls as would normally be done. Then, assuming the trigger is some user input (i.e. a button clicked in a hero card or a bit of text input), when the bot receives the request then it can initiate the API call.
The only thing you need to be aware of is the Azure Bot Service connector expect the bot to respond within 15 secs. While your API call may typically respond well within that time frame, the best practice is to not wait on the API response in order for the bot to respond. If there was ever a delay (network latency, server is slow to respond, etc.) then this "long running" process will result in a timeout error. To avoid this, have your bot respond immediately to the user's request with something like "the request is being processed" and, once the response is returned then send the response using a proactive message. The BotBuilder-Samples repo has a sample, 16.proactive-messages, that is available in all supported languages.
Steven Kanberg
@stevkan
:point_up: February 12, 2022 7:34 AM @Ussr-eng - if there is no way in Skype to directly reference the bot when sending an attachment, unfortunately, the answer is no. However, there may be an indirect way. If it's possible to call an API from Skype that would include the attachment in the request, you could then setup Azure Function (or similar) to receive that call. The function, when it's API is called, would trigger sending a proactive message to your bot to include the attachment and the conversatoin reference. I don't know if this is possible and would require some research on your part. This is the only way that pops into mind.
Jeremy Combs
@jmcombs
I have a question regarding the Webex Adapter, specifically for JavaScript that is published as botbuilder-adapter-webex. In the adapter's package.json it states the version should be 1.0.10 and also lists a dependency on botkit 4.15.0. Both of these package versions are not on NPM and the versions that are on NPM are two years old: botkit 4.10 and botbuilder-adapter-webex 1.0.9. So, it errors out on installing the botkit dependency and throws a bunch of warnings and depreciation warnings on dependencies for the Webex adapter. It looks like this is tied to the main mono repo of botkit still showing version 4.10 but I'm purely guessing. I opened this issue under the botkit repo since that's where this adapter lies howdyai/botkit#2203 but I intend to use the Webex Adapter in botbuilder, since that is the preferred package. Can someone point me in the right direction to how we can get these packages updated on NPM?
Jeremy Combs
@jmcombs
Also, it would be nice if someone would incorporate or approve the PR that was submitted for fixing this issue howdyai/botkit#2195
Jeremy Combs
@jmcombs
I’m curious, if this is not the method for speaking with the BotBuilder developers or developer support, can someone point me to what the official method is for engaging with BotBuilder developer support? With Cisco Webex, at least there’s a Webex Space where the DevSupport team are constantly helping out the community with issues.
Zakaria Amine
@zak905
Hello everyone, when I call the create conversation API, I get usually 201 with a response (which the expected response), but there are sometimes where 202 is returned with no response. I don't how frequent is that, does this depends on how busy the backends are ?
according to the docs https://docs.microsoft.com/en-us/azure/bot-service/rest-api/bot-framework-rest-connector-api-reference?view=azure-bot-service-4.0#http-status-codes, a 202 means that: The request was accepted for processing.
Zakaria Amine
@zak905
this group seems dead
Afeez Ishola
@waleyson
Hello Guys, Please i am having issues with testing my bot using Java SDK here is the error i am getting: Caused by: com.microsoft.bot.connector.authentication.AuthenticationException: Invalid AppId passed on token
fedsp
@fedsp
Unfortunatelly seems dead. And good luck requesting azure support, they will say that the bot framework is out ot scope of azure support
Zakaria Amine
@zak905
really !? well thanks for the heads up
Roberto Perdomo Macedo
@robertop23
Hello guys. Somebody know why I cannot create a teams conversation from a bot using a post to https://smba.trafficmanager.net/apis/v3/conversations? I'm getting this error: "Bad format of conversation ID"
Adam Leffert
@mindmodel
@fedsp Could I ask you to clarify? Do you mean that Bot Framework is dead, or some part of it, or this forum?
Steven Kanberg
@stevkan
@robertop23, if you are still having the issue, can you share the code on how you are sending the activity?
christophmeier80
@christophmeier80
Hi all. I'm looking into the Azure Bot Outlook Channel that is currently in preview. Does the channel support SSO and / or OAuthCard?
Sumeet Chandel
@chandelsumeet
Hi all . I am trying to build a chatbot with with authentication and qnamker service . I am using github template for authentication . After authentication how can i use qnamkaer service to answer the user questions
qatrick
@qatrick

Hello,

I simply follow https://docs.microsoft.com/en-us/azure/bot-service/bot-service-quickstart-create-bot?view=azure-bot-service-4.0&tabs=python%2Cvs and attempt to test bot framework w a ubuntu wsl env w the following config but seems there are aiohttp error when i attempt to localhost:3978. Anyone can advise?

$ python -V
Python 3.8.3
/my_chat_bot$ pip list|grep aiohttp
aiohttp 3.7.4.post0
botbuilder-integration-aiohttp 4.14.2

======== Running on http://localhost:3978 ========
(Press CTRL+C to quit)
Traceback (most recent call last):
File "/home/itrs/repo/bot2/venv/lib/python3.8/site-packages/botbuilder/core/integration/aiohttp_channel_service_exception_middleware.py", line 20, in aiohttp_error_middleware
response = await handler(request)
File "/home/itrs/repo/bot2/venv/lib/python3.8/site-packages/aiohttp/web_urldispatcher.py", line 870, in _handle
raise self._http_exception
aiohttp.web_exceptions.HTTPNotFound: Not Found
Traceback (most recent call last):
File "/home/itrs/repo/bot2/venv/lib/python3.8/site-packages/botbuilder/core/integration/aiohttp_channel_service_exception_middleware.py", line 20, in aiohttp_error_middleware
response = await handler(request)
File "/home/itrs/repo/bot2/venv/lib/python3.8/site-packages/aiohttp/web_urldispatcher.py", line 870, in _handle
raise self._http_exception
aiohttp.web_exceptions.HTTPNotFound: Not Found

Kai Laptop
@KaiLaptop_twitter
Hey
how do i advance my bot past repeating my messages, eg implement machine learning
valley
@0vally1
hi, everyone, I'm new, how to quickly create a teams notification bot, python or go
Anand Padiya
@anandcpadiya
Exception Message: Tried to get token using Managed Service Identity. Access token could not be acquired. A socket operation was attempted to an unreachable network.)
priya.goswami
@priya.goswami:matrix.org
[m]

HI, everyone I am not getting any proactive notification to my teams bot.

After using below attached references for proactive message I tried to send proactive message using bot framework emulator and added localhost url, MicrosoftAppId and MicrosoftAppPassword in emulator also added the MicrosoftAppId and MicrosoftAppPassword to proactive code, when I started process to test this app on emulator I am getting unauthorize error.
Now I'll try to host it on any web server to check this issue.

I have followed below references :

- https://github.com/MicrosoftDocs/msteams-docs/blob/master/msteams-platform/assets/downloads/SendProactiveMessages.zip
- https://docs.microsoft.com/en-us/microsoftteams/platform/sbs-send-proactive?tutorial-step=3
baluvijay
@baluvijay
hi, is there a way to create a notifcation bot without having a for loop , the teams toolkit one has a for loop like bot.notifications.installations
I want an api endpoint in bot to which i can provide a channel Id and the bot should be able to push an adaptive card into the channel Id if its installed there
does anyone here have created something similar to it?
Preeti Duhan
@preetiduhan
Hi, I am from MCIGET team, and I need to send proactive message from my application to teams user(not to channel/group) but one to one to real user in teams.(trying to implement notifications) I was reading bot documentation and it is achievable.
I wanted to know how a bot will make first time conversation with user for sending proactive message(notification) since user is not sending anything to bot. How we will we get teams user details?
Can someone please help on issue I am seeing: https://stackoverflow.microsoft.com/questions/318807
John Day
@johnmiroki
@preetiduhan Can loggin that stackoverflow which is an enterprise edition. But I am able to send proactive message to users who have already installed the app. You must know the user's aadObjectId and the app's aadObectId, then you acquire the teamsAppId, and then you got the chatId aka conversation Id, then you'll be able to send the proactive message
Yukari
@Yukari-Tryhard
Hello sorry for bother. Can i have docs of BotBuilder v3 . I can't find it anywhere
Steven Kanberg
@stevkan
@Yukari-Tryhard - As BotFramework v3 is deprecated, you are unlikely to find the docs anywhere. Your best bet for information would be to look over the BotBuilder-V3 repo. There is a host of information there though you will have to root around, and plenty of samples that cover most (but not all) situations.
Pablo Ariel Di Loreto
@pablodiloreto
Hello team! Do you know about any news about "Custom Question Answering" support in "Bot Framework Composer"? Any update about the Bot Framework Composer roadmap? Thank you.
Augusto Altman Quaranta
@augusto-altman
Hello all! I have a quick question. Does the bot framework implement some sort of buffering when sending events TO my bot? I am working on a Teams bot and I am worried that my bot would not be able to handle the incoming events if many of them are sent simultaneously to my web service (API)
4 replies
bkmaibach
@bkmaibach
Hello everyone, I am wondering if anyone knows how to include team ID information when executing a message extension action?
Nick Francis
@nickfrancis
Hi all. Is there a way of implementing Web Chat with Direct Line Extension when building a bot using Bot Framework Composer? Unable to add Named Pipes to startup.cs as that breaks the Bot in Composer....
bkmaibach
@bkmaibach
Hello all, I am trying to find a way to add a locally hosted app to a channel, so that the bot is a part of the conversation roster within a team. Is there any way to do this? For some reason, I can only get the bot to add as a personal chat. I have changed the default install scope to the app to be "team" and have attempted to find the bot when using "@" -> add bot, but only published bots appear. I really need to be able to add a bot to a team so that I can acquire the relevant team ID for my third party application. Thank you so much for any ideas, leads, things to try, or even encouragement!
I have read the following, but while there is a section on "removing a bot from a team" there does not seem to be one for adding a bot to a team:
https://docs.microsoft.com/en-us/microsoftteams/platform/resources/bot-v3/bots-test
"Error: The bot is not part of the conversation roster"